Galleon Wallet NFT Gallery


I am having trouble loading my NFTs on the galleon wallet. All it does is show a loading symbol, no NFT is being displayed.

What can possibly be the issue? I made sure the NFT’s were located in the wallet, and they are. Seems to me like its something with the server?

Which version of the wallet are you using and which operating system are you on?

Do you know whether you are behind a proxy?

1 Like

I am not using a proxy.

  • Galleon 1.3.5 (62)

  • I am using the latest version of Ubuntu (Linux)

Thank you

We are not aware of any issue at the moment with that OS and wallet version. We have asked our team members to try to re-create it.

In the meantime, if you are comfortable doing it, you could also send your Tezos address to with a link to this thread. No worries if you don’t.

Looks like the IPFS gateway by Cloudflare that we are using with Galleon is experiencing intermittent issues.

Are you still having problems? If so, we will look into switching to a different provider in the new year.

The issue is still happening. I will send support a message with my address to investigate this further. I think to re-create the error you would need to send an NFT from temple wallet to a galleon wallet, but the galleon wallet NFT gallery must be empty at first before you send an NFT, and then after you send the NFT; you would have to add the NFT contract so that it could display in the gallery. This how I created the error. But it most likely is coming from either the backend or cloudflare. The staking and amount of tezos is display currently and updating properly. It’s only the NFT Gallery that is causing issues.

I sent an email to support

I had a thought; would changing the node the wallet is using make a difference?

Thank you,
Legendary Hands

Hi @LegendaryHands

I tried to replicate the steps you mentioned and was able to see my NFT. Here’s what I did:

  1. Sent an NFT from my Temple wallet to a brand new one on Galleon. No previous NFTs were in the gallery.
  2. While the gallery was showing a spinner I added the contract for the collection.
  3. Block explorer indicated that the transfer was successful but I still only saw the loader. After a few minutes the NFT did indeed show up.

The NFT collection that I added was from OBJKT so it’s possible that it’s easier to parse than some others. Are you having trouble with other NFTs as well?

Not sure if changing nodes would make a difference but it couldn’t hurt to try and see.

Let us know how it goes!

I am still having the same issue. I have not tried any other NFT’s, as I am trying to get this one to work before I send any other one. Is there anything else I can try? It just show’s the spinner spinning. I tried removing the contract and doing it again. Same issue is happening just a rotating spinner. To be specific;
the actuall NFT that was sent is Cheetez NFT contract address: KT1LRLiZni9vRBUf78bzkKcAxTdchY1k5WjE

I still need help. Support hasn’t replied to me through email yet?

Hi @LegendaryHands

One of the devs tested this contract and Galleon wasn’t able to parse the contract correctly. Unfortunately, you won’t be able to interact with it in the wallet gallery.

You do have the option of using itself to manage and send the NFTs in this collection. You can can simply send the NFT to a different wallet address using OBJKT or you can import your account into another wallet that might let you manage it.

Thanks for sticking by while we took a look.

1 Like

Good morning navi,

Thank you for confirming and finding out this issue. I truly appreciate it. I am glad the issue is not with Galleon, and actually just the parsing of the contract. I will connect my wallet to objkt and send the NFT to a different wallet to manage it.

-I can happily say this thread is solved.

Thank you,